DOSBox 0.74 Crusader Guide

Re: DOSBox 0.70 Crusader Guide

Hello all,

I have No Regret running fine in 0.70 with everything but full button access on my joystick.  I've searched through the forum and haven't found a tweak to fix it yet, hope someone might have an idea.

I have a SAITEK X45.  The stick is recognized fine in dosbox.  The stick is sending all the buttons to the game but the game seems to only see/act on 1-4. (if I press the other keys I get the same 1-4 actions instead)  I have tried all the diff dosbox cfg settings and also tried joytokey tool. 

I have also noticed something strange that may or may not be related.  I used the crusader.cfg of the game to edit the joystick buttons, assigning all available to me (1-4, 7, 8, and LHAT 15-18).  But everytime I run the game through DOSBox the crusader.cfg reverts back to the original button settings.  As soon as I open it back up in winxp it has been rewritten.  I don't know where or why it would be rewriting or recompiling the cfg each start.

I have read some info saying dosbox only emulates max 4 buttons, is that a hard limit that I just can't get past?

Any insight appreciated.

P.S.  reason for joystick is back in WIN95 day I was able to run entire game with SideWinder using just the buttons set up in crusader.cfg, was easier than keybd/mouse.
Re: DOSBox 0.70 Crusader Guide

Sorry, I don't have any experience with joystick problems.  :(
Re: DOSBox 0.70 Crusader Guide

from what I got, before DOSBOX you managed to use more than 4 buttons of joystick, right?

It's just now you can't use more than 4, if you are playing through DOSBOX?
Re: DOSBox 0.70 Crusader Guide

Well, its been a really long time but I could have sworn that I could use all the buttons on a MS Sidewinder 3D pro, that means 5-8 on the base as well as the basic 4.

And like I said, the crusader.cfg keeps rewriting to only show 4 buttons, so maybe my memory is bad and the game is hard coded to only recognize a total of 4 no matter what and DosBox is doing fine. Else I've got something rewriting the button= lines everytime I load up.

Worst case I'm about to boot up an old P75 box with only DOS on it to see what I get, I've got some other joysticks as well, the X45 is only USB.
Re: DOSBox 0.70 Crusader Guide

Well, I found another way around it, my X45 is using custom software, so I removed all the DirectX button sends and only mapped the commands in the readme.txt.

So know the game should only be receiving the mapped commands and no direct button actuations.

I still see that the crusader.cfg is resetting to the default button= list, maybe it does that everytime you try to calibrate, but then the readme is wrong saying you can modify the button= list.

Anyway thanks for all the help, now its off to finally finish the game, I never did before it crashed a long time ago on a late level.
Re: DOSBox 0.70 Crusader Guide

My Crusader No Remorse works flawlessly except when the level ends and I get a blank screen.  This is really frustrating me and I don't know how to solve it.  I'm using Dosbox 0.70 and I have a decent computer.  It doesn't mess up anywhere except when I try to go back to base.
Re: DOSBox 0.70 Crusader Guide

I'm having the problem with the game loading up fine and then when I go to start playing, the background is black and the movement leaves trails.  I know someone mentioned something about this problem earlier, but I couldn't find anything about a fix.  If anyone has any advice, it'd be much appreciated.

And this isn't a pirated copy.
dosbox crusader problem

hello, i have succesfully installed crusader no remorse through dosbox and it boots up and is working wonderfully... except i have no sound or music i have no idea what is causing the problem
any ideas, please help me
Re: DOSBox 0.70 Crusader Guide

Did you set up your soundcard in the installation process?
Re: dosbox crusader problem

Jason link said:
hello, i have succesfully installed crusader no remorse through dosbox and it boots up and is working wonderfully... except i have no sound or music i have no idea what is causing the problem
any ideas, please help me

During the installtion configuration it asks "Would you like Digital sound effects" answer Yes and choose Sound Blaster Pro, Port 220,Irq 5,DMA 1 (If you din't reconfigure standart settings of DOSBox)
Re: DOSBox 0.70 Crusader Guide

Good news all! I have installed my pukka copy of No Remorse a friend gave me years ago (pre-empting the arrival of my No Regret eBay copy coming soon!) to see if I could get the DOSBOX settings right.

Installed everything ok no worries, installed patches.

Seems to be the area that there is no definitive answer to is the cycling. I have a Centrino 1.8GHz running XP, 1024MB RAM.

I've done a sweep on other people's experiences and will try tonight to fix the problems I've encountered so far:

1) Sound plays ok for a while then skips and repeats this
2) Get distorted sprites of the silencer, weird purple colouring on him!
3) Slow movement

I know that the virus scan was running last night so I'll disable that and try the auto cycling option to see if it helps.

Otherwise, it's playable as it is, great success!
Re: DOSBox 0.70 Crusader Guide

Great! Yeah, the auto-cycles feature is so great.
Re: DOSBox 0.70 Crusader Guide

Each time I try to install Crusader No Remorse it's says ther's not enough place... But I have 7Go free and the game only needs 55 megs.  And at the top of the window it's says that I have 0 Mo free on my Hard disc...

Re: DOSBox 0.70 Crusader Guide

Sorry, didn't see the end of the 1st post, so how do I creat a folder priori ?
Re: DOSBox 0.70 Crusader Guide

Well, I know how to make that, but it it still doesn't works. I need to creat the folder in C: ,right ?

PS: English is my 2nd language, and I have a Disortographia, sorry if I do spelling mistaks.
Re: DOSBox 0.70 Crusader Guide

To wherever you want to install it. If you want to install it to C:\Crusader, put a folder named 'Crusader' in C:\.
Re: DOSBox 0.71 Crusader Guide

Hi : :'(

I surf the cybernet , I pick up every information possibly , but the problems still exist . Please , help me .

I type the comment as followed >:D

mount d d:\ -t cdrom            "Of course my laptop has only two disk : c for hard disk and d for CDROM" >:D

the message is "There is too little space to install Crusader , or something like that" >:D

My C hard disk is 60GB
CPU : I don't know , but I bought it two years ago .
OS  :  XP

I don't kow how to solve the problem  ,  and I do not plan to install DOS 7.01 . Is there any way to give me a hope toward the crusader ????

Please let me know . My E-mail :

Best Regaards                  pipipupu from Taiwan .
Re: DOSBox 0.71 Crusader Guide

Hi pipipupu,

You need to create the folder where you're going to install Crusader before actually installing it.